Chat
Contact us
Close contact box
Connect ID #
045 521 313 3
Connect ID #
045 521 313 3
All finished with your chat session?

We’ll email you a transcript of this conversation for your records.

All of our representatives are
currently chatting with other customers.

Please enter your name.  
Please enter a valid email address. Why is this required?
Please enter your US phone number.  

For Tech Support, call 1-888-292-2575

Thank you, !
Our conversation will be emailed to
Please enter a question  
Don't wait on hold. We'll call you back when it's your turn to talk with the next available .
Please enter your name  
Please enter your phone number  

Please enter a message  

Calls may be recorded for training and quality control purposes.

We are located in Virginia USA.

Timothy D's 2007 Chrysler 300

Items installed:

  • JVC Mobile Arsenal CD/USB receiver
  • Alpine MRP-F300 50X4 amplifier
  • Memphis ClassD 1100w at 1 amplifier... running 350 at 4 ohm
  • Harmon Kardon 25X2 amplifier
  • 2 Bose 4-3/4" mid speakers
  • 2 Clarion 4" mid coax speakers- disguarded tweeters though
  • 2 Rockford Fosgate 3-1/2" mid speakers
  • 1 Cerwin Vega 18" Stroker single 4ohm vc
  • Walmart wire. 2 amp kits, y-rca's, 2 spools of wire, extra rca patch cable, antenna adapter
  • Harbor freight tools - box of crimp connectors
  • Elite Audio - Large crimp connector and advice on bypassing no remote on in dash

Installation Description

Had JVC Arsenal deck in '02 explorer and traded car after reinstalling factory components. Took all of about a minute to miss the JVC and its clarity from the factory stereo in the '07 300. Went to buy sub amp and ran into long time friend and stereo fanatic. He worked at a bodyshop and said his girlfriend was destroying his stuff and that he had an Alpine bought from Crutchfield he would part with because it would end up broken. That Alpine blew a G&S OD Redline 10" sub into pieces, and i had to pull out my Cerwin Vega 18" Stroker. Then I needed more power: the Memphis Class D amp. The empty holes in dash for 3-1/2" made perfect homes for the Rockford Fosgate speakers i had for about 10 years still in box. They are powered by the HK amp with in line crossovers. After blowing the rear 6X9's; I made wood plates with 3/4" MDF and a Dremel to hold the Bose 4-3/4" and Clarion 4" speakers. The Alpine power's them and the still-factory front doors.

Q&A Section


Why did you decide to upgrade your A/V system?

Audiophile since 1991


What's the first thing you show people about your installation?

monster sub


Why did you choose these products?

have owned about 5 alpine amps. really love MRP-F300, and owned a kenwood excelon deck. which was stolen, JVC Arsenal deck really has control and options galore


What was the most difficult part of the installation?

freezing rain


What plans, if any, do you have for future upgrades?

JVC DVD deck, Alpine MRP-M1000 or M2000 amp to replace Memphis amp, and front door speakers


Amp Alpine amp under the seat
tweeter Dash opening for 3-1/2" speaker
dash mess A disassembled dash
wiring kit The wiring kit
subwoofer The subwoofer
car My Chrysler

Vehicles in the Customer Car Showroom are submitted by customers and fans, and edited by Crutchfield writing staff. You can find more of these articles on the Showroom main page.

Please share your thoughts below.

  • Susan Rich from Schenectady ny

    Posted on 9/9/2020

    Hey how's it going?my radio on my 2005 Chrysler 300 is having a issue with am fm and the screen itself is only Coming on and off,when am is pushed I can't push anything else.no cd ,I can't move it back to fm it is stuck on only 1 thing do you think it might be a wire loss under the seat or a fuse?please I need help.

    Robert Ferency-Viars from Crutchfield

    on 9/10/2020

    Hey there Susan. It's hard to say what could be causing that behavior. Did you change anything in the car before this started happening? Add some electronics or an amplifier, for example? If you didn't touch anything in the car, then it shouldn't a loose or interrupted connection. It could be that the radio is going bad, especially if all other electronics are working okay. It would take a technician some time with a multimeter to figure it out.
  • Richard Darrell Sheridan from Romney

    Posted on 4/5/2019

    Would like to see pics of after install. Not a bunch of wires on the floor and sub on the living room floor.

  • bubba from folsom

    Posted on 8/6/2015

    Im sure its nothing close to audiophile sq with that cv stroker lol